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Capital Projects Summary Report – Start to Finish 
This section follows the standard approach to report design detailed in “Basic Concepts” to create a report showing 
Revenue and Expenditure budget amounts (Budget Structures 42 and 43), as well as revenues and expenditures against 
those budgets.  Here is summary information about this report (following the conventions detailed in “Basic Concepts”: 

Item Name Filters Objects/Variables 
Document Capital Projects – Budget, Revenues, Expenditures 
Universe(s) FIN-Budget Vs Actual 
Query(s) FIN-BUD Data Department InList Prompt 

Fund InList Prompt (optional) 
    OR 
Fund Matches Pattern Prompt 
(optional) 

Filter objects (& names) 
Department Name 
Fund Name 
Object 
Object Name 
Revenue Source 
Revenue Source Name 
Adopted Revenue Budget(42,1) 
Amended Revenue Budget(42,1) 
Adopted Revenue Budget(42,2) 
Amended Revenue Budget(42,1) 
Collected Revenue 
Encumbered 
Actual Expenses 

Report(s) Level 1 
Level 2 
For Export 

None Prompt variables 
AMT-Bud1 
AMT-Bal1 
AMT-Bud2 
AMT-Bal2 
AMT-Enc 
AMT-Exp 
AMT-Rev 
AMT-Net 

I. Query Design 
A. Name the report and Save it – The best universe for a Capital Projects Summary report at this time is 

the FIN-Budget Vs Actual universe.  Note: For a Capital Projects Detail report (including Document 
Numbers), you would need to merge the query of the Summary report with a query (or queries) against 
FIN-General Accounting for expenditure and revenue detail.  Since we need a query for the Summary 
report with at least one object in it to save our initial report, the first step is to create a query against 
FIN-Budget Vs Actual universe. 

1. Drag [Department] and [Department Name] (from Budget vs Actual > COA-Organization > 
Organization-Centralized view) to Result Objects. Rename your query tab to “FIN-BUD Data”. 

2. Use the “Close” button to “Close and apply changes”.  (This takes you to the Report Panel.) 
3. Click the “Save” button to save the report to your “My Favorites” folder with a meaningful name 

(such as “Capital Projects – Budget, Revenue & Expenditures). 

PAUSE & REFLECT:  Why did we save a query with only one object? 
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B. FIN-General Accounting universe query – No FIN-General Accounting query is required for this report.   
C. Other universe queries –Edit the FIN-BUD Data query, pulling the following objects: 

1. Budget vs Actual > COA - Fund Accounting class – Pull the following objects: 

Description Sub-Class Objects 
Fund  Fund Fund  

Fund Name 
Object  Object Object  

Object Name 
Revenue Source Revenue Revenue Source 

Revenue Source Name 

2. Budget vs Actual > COA – Organization class – Pull the following objects: 

Description Sub-Class Objects 
Department Organization - Centralized 

view 
Department 
Department Name 

3. Budget Template Measures class – Pull the following objects: 

Description Sub-Class Objects 
Summary Adoption Amount Budget Structure 42 

     Structure 42 Level 1 
Adopted Revenue Budget(42,1) 

Summary Amendment Amount Budget Structure 43 
     Structure 42 Level 1 

Amended Revenue Budget(42,1) 

Detail Adoption Amount Budget Structure 42 
     Structure 42 Level 2 

Adopted Revenue Budget(42,2) 

Detail Amendment Amount Budget Structure 43 
     Structure 42 Level 2 

Amended Revenue Budget(42,2) 

4. Expense Measures class – Pull the following objects: 

Description Sub-Class Objects 
Encumbered Amount  Encumbered 
Expense Actual Amount  Actual Expense 

5. Revenue Measures class – Pull the following objects: 

Description Sub-Class Objects 
Revenue Actual Amount  Collected Revenue 

6. Query Filters – Drag the following objects from Result Objects to Query Filters to create filters 
(see the section on “Nesting” in Basic Concepts to nest the Fund query filters using [OR]): 

Object Operator Values Optional? Default Values 
Department In List Prompt: Enter Department: No  
[OR]Fund In List Prompt: Enter Fund(s) (optional): Yes  
[OR]Fund Matches Pattern Prompt: Enter Pattern for Fund 

(% wildcard) (optional): 
Yes C8% 

7. Prompt Order – Open Query Properties and arrange the prompts in the order shown above. 
D. Save the report – Once again, “Apply changes and close”, then save the report with the “Save” button. 

PAUSE & REFLECT:  What is the advantage of having the two optional Fund prompts? 
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II. Report Design – Refresh the report as needed while you design your report. 
A. Default report design – Make the following changes to the generated report: 

1. Delete the title box and the table block. 
2. Rename the report tab from “Report 1” to “For Export”. 
3. Save the report. 

B. Add table block – Add the table block back as follows: 
1. Hold your “Ctrl” key down while you select the following objects, then drag them into the report 

and arrange them in the following order (add “Name” objects as desired): 

Objects for Table Block 
Department 
Fund  
Revenue Source 
Revenue Source Name 
Adopted Revenue Budget(42,2) 
Amended Revenue Budget(42,2) 

Tip:  For reports having only one query, the table is automatically created with the objects in the 
order in which you select them. 

2. Position the table at the top of the page (i.e., Horizontal Position = 0, Vertical Position = 0). 
C. Report & Table filters – None needed for this report. 
D. Report data & variables – Make sure the data is complete and totals are correct.  Tip: A quick way to 

compare amounts within the report is to duplicate it, then add breaks and column totals. 
1. Confirm Budget Amounts: 

a. For simplification, create a measure variable named “AMT-Bud2” with the following 
formula: 
 AMT-Bud2 = [Adopted Revenue Budget(42,2)]+[Amended Revenue Budget(42,2)] 

b. Add [AMT-Bud2] to the table (as the last column), then save the report. 
c. Spot-check [AMT-Bud2] amounts in the table, comparing them with the Current Budget 

amounts on the eMARS inquiry page for Revenue Budget 42, Level 2 (BQ42LV2) for the 
Fund.  Note: We are using the Revenue Budget (Budget Structure 42) level measures, 
but another option would be the Expense Budget (Budget Structure 43) level measures.  
In general, the amounts will match, but you should consider each case carefully. 

d. Remove [Adopted Revenue Budget (42,2)] and [Amended Revenue Budget(42,2)] from 
the table and save the report. 

2. (optional) Combine Object and Revenue data: 
a. Add [Object] and [Object Name] to the table (as the last columns). 
b. Create a dimension variable named “DIM-Obj/Rev” with the following formula: 

 DIM-Obj/Rev= If(IsNull([Object]);[Revenue Source];[Object]) 
c. Add [Dim-Obj/Rev] to the table (after [Revenue Source Name]). 
d. Create a dimension variable named “DIM-Obj/Rev” with the following formula: 

 DIM-Obj/Rev Name= If(IsNull([Object]);[Revenue Source Name];[Object Name]) 
e. Add [DIM-Obj/Rev Name] to the table (after [DIM-Obj/Rev]). 
f. Remove [Object], [Revenue Source], and [Revenue Source Name] from the table. 

PAUSE & REFLECT:  What is the advantage of having only one column for Object and Revenue Source? 
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3. Confirm Encumbered and Expended Amounts: 
a. For consistency, create a measure variable named “AMT-Enc” and set it equal to 

[Encumbered].  Add [AMT-Enc] to the table (after [Object]), then save the report. 
b. For consistency, create a measure variable named “AMT-Exp” and set it equal to [Actual 

Expense].  Add [AMT-Exp] to the table (after [AMT-Enc]), then save the report. 
c. Spot-check the [AMT-Enc] and [AMT-Exp] amounts in the table, comparing them with 

the Encumbered and Actual Expenses amounts on the eMARS inquiry pages for Expense 
Budget 43, Level 2 (BQ43LV2) for the Fund. 

4. Confirm the Balance Amount: 
a. Create a measure variable named “AMT-Bal2” with the following formula: 

 AMT-Bal2 = [AMT-Bud2]-[AMT-Enc]-[AMT-Exp] 
b. Add [AMT-Bal2] to the table (after [AMT-Exp]), then save the report. 
c. Create a break on [Fund] (by right-clicking the column and selecting Break > Add Break). 
d. Create break totals (by right-clicking each amount column and using the “Sum” button 

in the Functions section of the Analysis tab in the toolbars), then save the report. 
e. Spot-check the [Amt-Bal2] totals in the table, comparing them with the Unobligated 

amounts on the eMARS inquiry page for Expense Budget 43, Level 2 (BQ43LV2).   
Note: When Expenditure budgets (Budget Structure 43) are used, the Budget amounts 
will appear on the same line as the Encumbrance and Expenditure amounts, potentially 
eliminating the need for breaks and totals. 

f. Fill the [AMT-Bal2] column with shading (using the “Background Color” button in the 
“Style” section of the “Format” tab in the toolbars), then save the report. 

5. Confirm the Revenue Amount: 
a. For simplicity, create a measure variable named “AMT-Rev” and set it equal to 

[Collected Revenue].  Add [AMT-Rev] to the table (after [AMT-Bal2]); save the report.   
b. Spot-check [AMT-Rev] amounts in the table, comparing them with Collected Earned 

Revenue amounts on the inquiry page for Revenue Budget 42, Level 2 (BQ42LV2). 
6. Create a Net Amount (Revenues vs. Expenditures): 

a. Create a measure variable named “AMT-Net” with the following formula: 
 AMT-Net = [AMT-Rev]-[AMT-Exp] 

b. Add [AMT-Net] to the table (after [AMT-Rev]), then save the report. 
c. Fill the [AMT-Net] column with shading (using the “Background Color” button in the 

“Style” section of the “Format” tab in the toolbars), then save the report. 
d. Spot-check the [AMT-Net] amounts to ensure they are being calculated correctly. 

PAUSE & REFLECT:  What do negative AMT-Net values indicate about the capital project? 

7. Create “Level 2” Report tab: 
a. Format all of the numbers in the table consistently, using the options in the “Numbers” 

section of the “Format” tab in the toolbars. Tip: See the “Start-to-Finish: Cash Control 
Report” section for steps to create custom number formats, if desired. 

b. Right-click the report tab and choose “Duplicate Report”.  Rename the new report 
“Level 2” and make it the first report tab. 

c. Set the column widths of each amount column to 1.5” (= 3.8 cm). 
d. Save the report. 
e. Remove the breaks and totals from the “For Export” tab (by right-clicking the Fund 

column and selecting Break > Remove Break). 
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E. Report headers and footers – If you are not using a report template, create a header and a footer for 
the Level 2 report tab according to the standards and conventions in use by your organization.  Ideally, 
these should include the execution date and time for the report, the page number, the report title, and 
any prompts and responses from the query filters.  (Refer to other Start to Finish sections for sample 
instructions and layout settings.)  Tip: There are standard cells for all of this information.  Select Report 
Element > Cell > Pre-defined in the toolbars to see a list of them. 

F. Sections – Create a section on [Department] (by right-clicking it and choosing “Set as Section”). 
G. Breaks – No additional breaks are required for this report tab. 
H. Totals – Verify that each column has totals, and if not, use the “Sum” button (located on the “Functions” 

section of the “Analysis” tab in the toolbars) to put totals in each column. Tip: If you format the amounts 
in the table before adding the totals, the resulting total numbers will automatically be formatted 
consistently with the amounts being totaled.  Create Section Totals and Grand Totals as follows: 

1. Create space in the Sections for a Totals table: 
a. Use the “Design” button to view the “Structure” of the report.  Notice that the bottom 

row of the existing table provides totals that will correspond to the Department level, 
but we will create a separate “Section Totals” table, so right-click the bottom row and 
select “Delete”, then “Remove Row”. 

b. Hover over the Department section of the report to find its bottom boundary, then drag 
the bottom boundary down to create space in which to work with a Section Totals table.  
Tip: If you are having difficulty selecting or moving the boundary, you can always use 
the “Document Structure and Filters” tab in the left panel to select the section, right-
click and “Format section…”, then add Bottom Padding (in the General section of the 
“Format Section” window). 

2. Create and format the Section Totals table: 
a. Using the “Vertical Table” button (located in the “Table” section of the “Report 

Element” tab in the toolbars), create a new vertical table in the space you just created.  
(Be sure the table is below the lower boundary of the Department section, but above 
the lower boundary of the Fiscal Year section.) 

b. Calculate the position of the first amount column in the main table, then set the Layout 
values (using Format Table) to position the Section Totals table in alignment.  (The 
Section Totals table will need to be positioned relative to the main table, but for now 
you may not want to address that – just to see what happens if you don’t.) 

c. Set the column widths of each column in the Section Totals table to 1.5” (= 3.8 cm). 
d. Each of the cells in the Section Totals table corresponds to an amount column in the 

main table.  Copy and paste the formulas from the table column total cells into the cells 
of the Section Totals table (adding columns as needed). 

e. Use the “Design” button to choose “with Data”.  If you did not position the Section 
Totals table relative to the main table, do so as follows: 

i Use the “Layout” tab of the “Format Table” window to set the Vertical Position 
to 0 cm, and change the “from the” value to “Bottom Edge”. 

ii Change the “of” value to “Block 1” (or whatever the name of your table block is 
– you can use the “Document Structure and Filters” section in the left panel to 
determine the name, if necessary.) 

iii Click “Apply”, then “OK”.  Your table should now be aligned correctly within the 
section, as the last item in the section. 

f. Spot-check your Section Totals to be sure they reflect the correct amounts for each 
Department. 
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g. Since this new table is only for totals, you can remove the table header (in the “General” 
section of the “Format Table” window).  This should leave you with a single row 
containing your totals.  (If you accidentally put your formulas in the header row of the 
Section Totals table, you must move, copy, or re-enter them in the remaining cells.) 

h. Go to the last page of the report, then move the bottom border of the section back up 
to eliminate unnecessary white space. 

PAUSE & REFLECT:  Could you include section totals using individual cells instead of a table? 

3. Create and position the Grand Totals table: 
a. Use Copy/Paste (or Ctrl-drag) to place a copy of the totals table below the bottom 

border of the section.  This new table will display the Grand Totals for the report.   
Tip:  The easiest way to do this is to go to Structure view, then drag the table below the 
bottom border, pressing the Ctrl- key on your keyboard and holding it until you see both 
tables, then releasing the table. 

b. Set the Layout values (using Format Table) to horizontally position the Grand Totals 
table in alignment with the Section Totals table, and setting the vertical amount to 0.  
Tip: If you used the tip above to copy the table, the “of” setting should automatically be 
set to what it needs to be (even though the value may not appear to be correct).  

I. Other reports – Copy the “Level 2” report tab to create an additional report named “Level 1”, then 
follow these steps to change the amounts to Level 1 amounts: 

1. Update Budget Amounts: 
a. Remove [Object] and [Revenue Source] from the table. 
b. For simplification, create a measure variable named “Amt-Bud1” with the following 

formula: 
 AMT-Bud1 = [Adopted Revenue Budget(42,1)]+[Amended Revenue Budget(42,1)] 

c. Replace [AMT-Bud2] in the table with [AMT-Bud1], then save the report. 
d. Spot-check [AMT-Bud1] amounts in the table, comparing them with the Current Budget 

amounts on the eMARS inquiry page for Revenue Budget 42, Level 1 (BQ42LV1) for the 
Fund.  Note: We are using the Revenue Budget (Budget Structure 42) level measures, 
but another option would be the Expense Budget (Budget Structure 43) level measures.  
In general, the amounts will match, but you should consider each case carefully. 

2. Update the Balance Amounts: 
a. Create a measure variable named “AMT-Bal1” with the following formula: 

 AMT-Bal1 = [AMT-Bud1]-[AMT-Enc]-[AMT-Exp] 
b. Replace [AMT-Bal2] in the table with [AMT-Bal1], then save the report. 
c. Spot-check the [AMT-Bal1] amounts in the table, comparing them with the Unobligated 

amounts on the eMARS inquiry page for Expense Budget 43, Level 1 (BQ43LV1). 
3. Confirm Revenue, Encumbered and Expense Amounts: 

a. Spot-check the [AMT-Enc] amounts in the table, comparing them with the Encumbered 
amounts on the Expense Budget 43, Level 1 (BQ43LV1) page in eMARS. 

b. Spot-check the [AMT-Exp] amounts in the table, comparing them with the Actual 
Expenses amounts on the Expense Budget 43, Level 1 (BQ43LV1) page in eMARS. 

c. Spot-check the [AMT-Rev] amounts in the table, comparing them with the Collected 
Earned Revenue amounts on the Revenue Budget 42, Level 1 (BQ42LV1) page in eMARS. 
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J. Save, review, correct, purge and publish– Complete formatting of your report according to the 
standards and conventions for your organization.  Normally, you would be designing this report for 
other users, so in addition to keeping a copy of the report in your “My Favorites” folder (or a sub-folder), 
you would want to put a purged copy in your Agency folder (or sub-folder).  Remember, your Agency 
folder is under your cabinet number on the “Folders” tab under Public Folders > eMARS Financial > 
eMARS Agency Reports. 

III. For Review and Discussion 
A. The Appropriation and Bureau Chart of Accounts elements are part of Budget Structures 42 and 43.  

Why are they not included in this report? 

B. Why does this report include the [AMT-Net] object?  Would it be useful in your organization in managing 
Capital Project budgets? 

C. What other objects would be useful as part of this report?  As part of other Capital Projects reports? 
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